Quick Start

The FAIR Data Pipeline needs three components to be installed on your computer in order to run. These are:

  • Command Line Interface (CLI)
  • (Local) Data Registry
  • A Modelling API (in whatever programming language you want to use)

Prerequisites #

The CLI needs to be installed using pip (the package installer for Python), which means you will need a Python distribution ( PyPI - Python Version) installed on your computer. You will also need to install Graphviz, if you would like to view provenance reports.

Install the Command Line Interface (CLI) #

Install the (Local) Data Registry #

Select and install a Modelling API #

Installation instructions for the Modelling APIs are in their respective GitHub repositories:

Try out an example #

Example models using the FAIR Data Pipeline are provided in each of the supported languages. Instructions to install and run these examples can be found in their respective GitHub repositories: